import Foundation
let pattern = #"([^\n]+?\.cpp)\((\d+),(\d+)\) : error: ([^\n]+)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
C:\Users\J\Documents\project\code\win32_jesse.cpp(772,70) : error: expected ';' after expression
AssetClock += Win32GetSecondsElapsed(LastCounter, EndCounter)
^
;
1 error generated.
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)