using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([^\n]+?\.cpp)\((\d+),(\d+)\) : error: ([^\n]+)";
string input = @"C:\Users\J\Documents\project\code\win32_jesse.cpp(772,70) : error: expected ';' after expression
AssetClock += Win32GetSecondsElapsed(LastCounter, EndCounter)
^
;
1 error generated.";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}