package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[A-Za-z]{8}(\d+.\d{2})`)
var str = `abcdefgh30.00000
abcdefgh300.0000
abcdefgh3000.00
abcdefgh3.00000
abcdefgh0.05000`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}