import re
regex = re.compile(r"[A-Za-z]{8}(\d+.\d{2})", flags=re.MULTILINE)
test_str = ("abcdefgh30.00000\n"
"abcdefgh300.0000\n"
"abcdefgh3000.00\n"
"abcdefgh3.00000\n"
"abcdefgh0.05000")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")