$re = '/[A-Za-z]{8}(\d+.\d{2})/m';
$str = 'abcdefgh30.00000
abcdefgh300.0000
abcdefgh3000.00
abcdefgh3.00000
abcdefgh0.05000';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);