re = /[A-Za-z]{8}(\d+.\d{2})/m
str = 'abcdefgh30.00000
abcdefgh300.0000
abcdefgh3000.00
abcdefgh3.00000
abcdefgh0.05000'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end