import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[A-Za-z]{8}(\\d+.\\d{2})";
final String string = "abcdefgh30.00000\n"
+ "abcdefgh300.0000\n"
+ "abcdefgh3000.00\n"
+ "abcdefgh3.00000\n"
+ "abcdefgh0.05000";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}