const regex = /[A-Za-z]{8}(\d+.\d{2})/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[A-Za-z]{8}(\\d+.\\d{2})', 'gm')
const str = `abcdefgh30.00000
abcdefgh300.0000
abcdefgh3000.00
abcdefgh3.00000
abcdefgh0.05000`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}