# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/a\.b\([^()]*\)(?=;)/\g<0>.c()/g;t' <<< "a.b();
a.b(param1=1);
a.b(param1=1, param2=2);"