const regex = new RegExp('a\\.b\\([^()]*\\)(?=;)', 'g')
const str = `a.b();
a.b(param1=1);
a.b(param1=1, param2=2);`;
const subst = `\g<0>.c()`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);