use strict;
my $str = 'a.b();
a.b(param1=1);
a.b(param1=1, param2=2);';
my $regex = qr/a\.b\([^()]*\)(?=;)/p;
my $subst = '\\g<0>.c()';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";