re = /a\.b\([^()]*\)(?=;)/
str = 'a.b();
a.b(param1=1);
a.b(param1=1, param2=2);'
subst = '\\g<0>.c()'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result