import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "a\\.b\\([^()]*\\)(?=;)";
final String string = "a.b();\n"
+ "a.b(param1=1);\n"
+ "a.b(param1=1, param2=2);";
final String subst = "\\g<0>.c()";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}