using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"a\.b\([^()]*\)(?=;)";
string substitution = @"\g<0>.c()";
string input = @"a.b();
a.b(param1=1);
a.b(param1=1, param2=2);";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}