import re
regex = re.compile(r"a\.b\([^()]*\)(?=;)")
test_str = ("a.b();\n"
"a.b(param1=1);\n"
"a.b(param1=1, param2=2);")
subst = "\\g<0>.c()"
result = regex.sub(subst, test_str)
if result:
print(result)