# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/([0-9.]+)/23/gm;t' <<< "<!DOCTYPE HTML PUBLIC \"-//W3C//DTD HTML 4.01 Transitional//EN\">
<html><head>
<META content=\"text/html; charset=utf-8\" http-equiv=\"Content-Type\">
</head><body>
<html>
<body>
[23]
</body>
</html>
</body></html>"