use strict;
my $str = '<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN">
<html><head>
<META content="text/html; charset=utf-8" http-equiv="Content-Type">
</head><body>
<html>
<body>
[23]
</body>
</html>
</body></html>';
my $regex = qr/([0-9.]+)/mp;
my $subst = '23';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";