const regex = /([0-9.]+)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('([0-9.]+)', 'gm')
const str = `<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN">
<html><head>
<META content="text/html; charset=utf-8" http-equiv="Content-Type">
</head><body>
<html>
<body>
[23]
</body>
</html>
</body></html>`;
const subst = `23`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);