# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"([0-9.]+)"
test_str = ("<!DOCTYPE HTML PUBLIC \"-//W3C//DTD HTML 4.01 Transitional//EN\">\n"
"<html><head>\n"
"<META content=\"text/html; charset=utf-8\" http-equiv=\"Content-Type\">\n"
"</head><body>\n"
"<html>\n"
" <body>\n\n"
"[23]\n\n"
" </body>\n"
"</html>\n"
"</body></html>")
subst = "23"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.