$re = '/([0-9.]+)/m';
$str = '<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN">
<html><head>
<META content="text/html; charset=utf-8" http-equiv="Content-Type">
</head><body>
<html>
<body>
[23]
</body>
</html>
</body></html>';
$subst = "23";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;