import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "([0-9.]+)";
final String string = "<!DOCTYPE HTML PUBLIC \"-//W3C//DTD HTML 4.01 Transitional//EN\">\n"
+ "<html><head>\n"
+ "<META content=\"text/html; charset=utf-8\" http-equiv=\"Content-Type\">\n"
+ "</head><body>\n"
+ "<html>\n"
+ " <body>\n\n"
+ "[23]\n\n"
+ " </body>\n"
+ "</html>\n"
+ "</body></html>";
final String subst = "23";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}