// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)([0-9.]+)").unwrap();
let string = "<!DOCTYPE HTML PUBLIC \"-//W3C//DTD HTML 4.01 Transitional//EN\">
<html><head>
<META content=\"text/html; charset=utf-8\" http-equiv=\"Content-Type\">
</head><body>
<html>
<body>
[23]
</body>
</html>
</body></html>";
let substitution = "23";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}