#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)([0-9.]+)"
Local $sString = "<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN">" & @CRLF & _
"<html><head>" & @CRLF & _
"<META content="text/html; charset=utf-8" http-equiv="Content-Type">" & @CRLF & _
"</head><body>" & @CRLF & _
"<html>" & @CRLF & _
" <body>" & @CRLF & _
"" & @CRLF & _
"[23]" & @CRLF & _
"" & @CRLF & _
" </body>" & @CRLF & _
"</html>" & @CRLF & _
"</body></html>"
Local $sSubst = "23"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)