# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/.*\/vp\/([^\/?]*?)\.[^\/?.]*(?:\?.*)?$/\1/gm;t' <<< "someurl.com/vp/125514_45147_55144.jpg?_nc25244"