using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @".*/vp/([^/?]*?)\.[^/?.]*(?:\?.*)?$";
string substitution = @"\1";
string input = @"someurl.com/vp/125514_45147_55144.jpg?_nc25244";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}