$re = '~.*/vp/([^/?]*?)\.[^/?.]*(?:\?.*)?$~m';
$str = 'someurl.com/vp/125514_45147_55144.jpg?_nc25244';
$subst = "\1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;