#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m).*/vp/([^/?]*?)\.[^/?.]*(?:\?.*)?$"
Local $sString = "someurl.com/vp/125514_45147_55144.jpg?_nc25244"
Local $sSubst = "\1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)