re = /.*\/vp\/([^\/?]*?)\.[^\/?.]*(?:\?.*)?$/m
str = 'someurl.com/vp/125514_45147_55144.jpg?_nc25244'
subst = '\\1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result