#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "\b(?:[^L\W]*L){2}[^L\W]*\b"
Local $sString = "match on specific character, multiple times but not necessarily consecutive" & @CRLF & _
"" & @CRLF & _
"I'm looking for a 'non consecutive' way to do something similar to how`{n}` works. Some examples, using the letter `L` , and using `L{2}` *incorrectly* just to demonstrate the desired outcome" & @CRLF & _
"" & @CRLF & _
"LLAMA - match" & @CRLF & _
"" & @CRLF & _
"SHELLS - match" & @CRLF & _
"" & @CRLF & _
"LEVEL \- match, even though the L's are not consecutive" & @CRLF & _
"" & @CRLF & _
"LOSER - no match number of L != 2" & @CRLF & _
"" & @CRLF & _
"LEVELLED - no match, number of L != 2 " & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")