import Foundation
let pattern = #"\b(?:[^L\W]*L){2}[^L\W]*\b"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
match on specific character, multiple times but not necessarily consecutive
I'm looking for a 'non consecutive' way to do something similar to how`{n}` works. Some examples, using the letter `L` , and using `L{2}` *incorrectly* just to demonstrate the desired outcome
LLAMA - match
SHELLS - match
LEVEL \- match, even though the L's are not consecutive
LOSER - no match number of L != 2
LEVELLED - no match, number of L != 2
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)