const regex = /\b(?:[^L\W]*L){2}[^L\W]*\b/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\b(?:[^L\\W]*L){2}[^L\\W]*\\b', 'g')
const str = `match on specific character, multiple times but not necessarily consecutive
I'm looking for a 'non consecutive' way to do something similar to how\`{n}\` works. Some examples, using the letter \`L\` , and using \`L{2}\` *incorrectly* just to demonstrate the desired outcome
LLAMA - match
SHELLS - match
LEVEL \\- match, even though the L's are not consecutive
LOSER - no match number of L != 2
LEVELLED - no match, number of L != 2
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}