// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"\b(?:[^L\W]*L){2}[^L\W]*\b").unwrap();
let string = "match on specific character, multiple times but not necessarily consecutive
I'm looking for a 'non consecutive' way to do something similar to how`{n}` works. Some examples, using the letter `L` , and using `L{2}` *incorrectly* just to demonstrate the desired outcome
LLAMA - match
SHELLS - match
LEVEL \\- match, even though the L's are not consecutive
LOSER - no match number of L != 2
LEVELLED - no match, number of L != 2
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}