package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\b(?:[^L\W]*L){2}[^L\W]*\b`)
var str = `match on specific character, multiple times but not necessarily consecutive
I'm looking for a 'non consecutive' way to do something similar to how\`{n}\` works. Some examples, using the letter \`L\` , and using \`L{2}\` *incorrectly* just to demonstrate the desired outcome
LLAMA - match
SHELLS - match
LEVEL \- match, even though the L's are not consecutive
LOSER - no match number of L != 2
LEVELLED - no match, number of L != 2
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}