using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\b(?:[^L\W]*L){2}[^L\W]*\b";
string input = @"match on specific character, multiple times but not necessarily consecutive
I'm looking for a 'non consecutive' way to do something similar to how`{n}` works. Some examples, using the letter `L` , and using `L{2}` *incorrectly* just to demonstrate the desired outcome
LLAMA - match
SHELLS - match
LEVEL \- match, even though the L's are not consecutive
LOSER - no match number of L != 2
LEVELLED - no match, number of L != 2
";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}