$re = '/\b(?:[^L\W]*L){2}[^L\W]*\b/';
$str = 'match on specific character, multiple times but not necessarily consecutive
I\'m looking for a \'non consecutive\' way to do something similar to how`{n}` works. Some examples, using the letter `L` , and using `L{2}` *incorrectly* just to demonstrate the desired outcome
LLAMA - match
SHELLS - match
LEVEL \\- match, even though the L\'s are not consecutive
LOSER - no match number of L != 2
LEVELLED - no match, number of L != 2
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);