# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(.*)(@\s?)(.*[^(\s\(\d+\))])(\s\(\d+\))?/$1 $3/gm;t' <<< "Second Title@ First Name Last Name
Second Title@ First Name Last Name (13)"