$re = '/(.*)(@\s?)(.*[^(\s\(\d+\))])(\s\(\d+\))?/m';
$str = 'Second Title@ First Name Last Name
Second Title@ First Name Last Name (13)';
$subst = "$1 $3";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;