re = /(.*)(@\s?)(.*[^(\s\(\d+\))])(\s\(\d+\))?/m
str = 'Second Title@ First Name Last Name
Second Title@ First Name Last Name (13)'
subst = '$1 $3'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result