#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(.*)(@\s?)(.*[^(\s\(\d+\))])(\s\(\d+\))?"
Local $sString = "Second Title@ First Name Last Name" & @CRLF & _
"Second Title@ First Name Last Name (13)"
Local $sSubst = "$1 $3"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)