// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(.*)(@\s?)(.*[^(\s\(\d+\))])(\s\(\d+\))?").unwrap();
let string = "Second Title@ First Name Last Name
Second Title@ First Name Last Name (13)";
let substitution = "$1 $3";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}