use strict;
my $str = 'Second Title@ First Name Last Name
Second Title@ First Name Last Name (13)';
my $regex = qr/(.*)(@\s?)(.*[^(\s\(\d+\))])(\s\(\d+\))?/mp;
my $subst = '$1 $3';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";