package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(.*)(@\s?)(.*[^(\s\(\d+\))])(\s\(\d+\))?`)
var str = `Second Title@ First Name Last Name
Second Title@ First Name Last Name (13)`
var substitution = "$1 $3"
fmt.Println(re.ReplaceAllString(str, substitution))
}