using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(.*)(@\s?)(.*[^(\s\(\d+\))])(\s\(\d+\))?";
string substitution = @"$1 $3";
string input = @"Second Title@ First Name Last Name
Second Title@ First Name Last Name (13)";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}