import Foundation
let pattern = #"(.*)(@\s?)(.*[^(\s\(\d+\))])(\s\(\d+\))?"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
Second Title@ First Name Last Name
Second Title@ First Name Last Name (13)
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1 $3"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)