# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(.*?)(fieldid=)*(')*(\d*)(')*/$4/gm;t' <<< "blah blah fieldid='123456'
blah blah
blah blah fieldid='123457'
blah
blah blah fieldid='123458'"