import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(.*?)(fieldid=)*(')*(\\d*)(')*";
final String string = "blah blah fieldid='123456'\n"
+ "blah blah\n"
+ "blah blah fieldid='123457'\n"
+ "blah\n"
+ "blah blah fieldid='123458'";
final String subst = "$4";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}