#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(.*?)(fieldid=)*(')*(\d*)(')*"
Local $sString = "blah blah fieldid='123456'" & @CRLF & _
"blah blah" & @CRLF & _
"blah blah fieldid='123457'" & @CRLF & _
"blah" & @CRLF & _
"blah blah fieldid='123458'"
Local $sSubst = "$4"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)