$re = '/(.*?)(fieldid=)*(\')*(\d*)(\')*/m';
$str = 'blah blah fieldid=\'123456\'
blah blah
blah blah fieldid=\'123457\'
blah
blah blah fieldid=\'123458\'';
$subst = "$4";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;