re = /(.*?)(fieldid=)*(')*(\d*)(')*/m
str = 'blah blah fieldid=\'123456\'
blah blah
blah blah fieldid=\'123457\'
blah
blah blah fieldid=\'123458\''
subst = '$4'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result