import Foundation
let pattern = #"(.*?)(fieldid=)*(')*(\d*)(')*"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
blah blah fieldid='123456'
blah blah
blah blah fieldid='123457'
blah
blah blah fieldid='123458'
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$4"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)